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Slope Stability 

Alessio FERRARI (AF) 

 
Exercise 9 

 

Stability evolution of unsaturated slopes during 

rainfall infiltration (FEM analysis) 

 

1   Exercise description 

 

The goal of this exercise is to perform soil slope stability analyses using a finite element code in which a 

coupled hydro-mechanical model is implemented taking into account the partial saturation of the soil. In 

particular, it is required to study the stability of the slope reported in Figure 1.a for the following conditions: 

a) a rainfall event of low intensity and long duration (0.012 m/h, up to 200 h); 

b) a rainfall event of high intensity and short duration (0.12 m/h, up to 20 h). 

 

The problem can be outlined as shown in Figure 1.b, where a simplified geometry is assumed and kinematic 

boundary conditions are defined. As initial condition, a water table coinciding with the slope toe can be 

assumed. The entire slope domain can be thought as composed of a Mohr-Coulomb material with the properties 

indicated in Table 1. 

 

Numerical analyses will be performed in a coupled way (hydraulic and mechanical behavior) by means of the 

finite element software ZSoil.  

 

ZSoil can be downloaded at the following website: https://www.zsoil.com/student/. Follow the installation 

instructions on the website to obtain the free student version.  

A tutorial is presented in section 2 in order to guide the student through the basic steps of ZSoil. The tutorial 

refers to ZSoil 2014 version (The link will download a newer version so there might be some small differences 

compared to this tutorial). 

 
 

  

 

 

 

 

Figure 1:  Case to study (a) and problem layout (b). 
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E Young’s modulus 100’000 kPa 

 Poisson’s ratio 0.3 - 

c' Cohesion 15  kPa 

’ Shear strength angle 23 ° 

 Dilatancy angle 0 ° 

 (Dry) soil unit volume weight 14.2 kN/m
3 

e0 Initial void ratio 0.9 - 

Kx, Ky Darcy’s coefficient 0.05 m/h 

Sres Residual saturation ratio 0 - 

 Saturation constant 0.1 1/m 

Table 1: Soil parameters. 

 

 

Consider that, in the case of unsaturated medium, the definition of effective stress adopted by the software is 

as follows: 
'
ij ij r ijS p  = −  

 

Where rS  is the degree of saturation (called by the software “saturation coefficient”) and p  is the fluid 

pressure. The relationship between the degree of saturation and the pressure of the fluid is defined as follows 
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where resS  is the residual degree of saturation (defined by the software “residual saturation ratio”), F is the 

unit weight of the fluid, and   is a material parameter.  

 

 

Work to be done 

For the initial state: 

1. calculate the pore pressure, effective stress and saturation degree distributions within the domain; 

2. calculate the initial safety factor. 

For each of the proposed cases: 

3. calculate the evolution of pore pressure and saturation degree with time within the domain and plot the 

displacements of some relevant points (A, B and C in Figure 1.b) versus time; 

4. identify the failure mechanism; 

5. evaluate the evolution of the safety factor with time; 

6. identify the maximum rainfall duration that leads to failure. 
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2 Tutorial for the solutions of the proposed cases with ZSoil v.14.10 

 

In the following sections a step-by-step tutorial is presented to solve the proposed problems with the use of the 

software ZSoil v.14.10. Three main steps will be accomplished: 

- a preprocessing phase, where all the input data are introduced (problem geometry, material properties, 

mesh, boundary conditions, driver definition,...); 

- the calculation step, where the boundary value problem is solved with the finite element method; 

- a postprocessing phase, in which the obtained results are displayed and analyzed. 

 

Notes 

- To indicate a command to be selected from a menu, the notation 'Menu > Submenu > Command' will 

be used. 

- Please take note of the positive sign convention for the stress field, defined with respect to a Cartesian 

coordinate system: 

 

 
 

Sign convention for the fluid pressures is adopted consistently with stress field convention, i.e. positive 

pressures (p > 0) are for tension, negative pressures (p < 0) are for compression. Same convention 

applies for the effective stress (positive in tension). Sign convention for the strains is adopted 

consistently with stress field convention, i.e. tensile strains are positive. 

 

 

2.1 Data input 

 

Set the Preference window with Analysis type: Plane strain, Problem type: Deformation + Flow, Unit system: 

Standard, Version type: Advanced. The Preference window can be recalled from the menu 'Control > Project 

preselection'. 

 

 
 

Save the project with 'File > Save as' in your personal folder. Remember to save regularly your project with 

'Ctrl + S'.  
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Select 'Control > Units' and take note of the unit system in use. Change the time unit in hours. 

 

2.1.1   Preprocessor 

 

From the main window of the software launch the preprocessor ('Assembly > Preprocessing'). The following 

window will appear. 

 

 
 

Set the construction lines ('Draw > Construction Axes'). Delete the actual positions ('Delete Axes'), then add 

the following positions writing the values in the position box and clicking 'Add': for the x axis 0, 20, 40, 50; 

for the y axis 0, 10, 30. 

 

 
 

Select the 'Draw > Create line' command icon and draw the shape of the slope with the help of the construction 

lines. Press 'Esc' when finished. 



EPFL - Faculté ENAC - Section de Génie Civil – Master semestres 2 and 4 – 2024-2025 

5 
 

 

 
 

Subdomains have to be created inside the drawn contours. On the right menu select 'MACRO MODEL > 

Subdomain > 2D continuum inside contour' and click inside the 2 contours. 

 

 
 

Seepage elements will be created in order to apply properly the hydraulic boundary conditions; these elements 

allow to simulate water run-off when a flux is imposed and the saturation ratio becomes equal to 1 (refer to 

the software theoretical manual for more information). Select the icon command 'Edges/Forces sel. > Select 

edge in zoom box' and highlight the subdomain edges indicated in figure, by drawing rectangles (from left to 

right) around them. On the right menu select 'MACROMODEL > Seepage > Create... On Subdomain edge(s)'. 

Answer 'Yes' to 'Create seepage on the selected faces' and click 'OK' in the 'Set parameters' window. 
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Unselect the edges from the menu 'Global selection tools > Unselect all'. 

 

Hydraulic boundary conditions will be introduced defining properly fluid pressures or fluid fluxes on the 

domain edges. 

 

 
 

A fixed piezometric head equal to 10 m will be assigned to the edges CD and DE, equivalent to a hydrostatic 

condition with the water table coinciding with the river level. Highlight both edges by means of the 'Select 

edge in zoom box' icon and use on the right menu the command 'MACRO MODEL > Pressure BC > Fluid 

head on the selected edges'. Input 10 (m) in the 'Fluid head' cell and press OK. 

 

 
 

‘Select edge in zoom box’ 
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For the edges AB and BC flux boundary conditions are assigned to simulate the rain infiltration. A flux equal 

to 1 is assigned to the edge AB and equal to 0.71 (≈ cos(45°)) to the edge BC (to take into account that rain 

intensity is conventionally referred to a horizontal surface). Assigning unitary value gives the possibility to 

control the value of the flux during the time by means of the definition of proper loading functions as explained 

later in the text. Unselect the edges from the menu 'Selections > Unselect all'. On the right menu use the 

command 'MACRO MODEL > Fluid flux > On Subdomain edge'. Click below the AB edge and insert 1 in the 

fields Value 1 and Value 2. Assign 1 to Load function, to be defined later. 

 

 
 

Repeat the same procedure for the edge BC assigning 0.71 to Value 1 and Value 2, and 1 to the load function. 

 

 
 

Not assigning any hydraulic boundary condition to the edges AF and FE is equivalent to identify them as 

impermeable boundaries. 

 

To create the mesh select on the right menu 'MACRO MODEL > Subdomain > Create virtual mesh' then click 

inside the upper subdomain. In the meshing parameters window select structured mesh type, with a 

quadrilateral mapping template. 4 red numbers automatically appear on the 4 subdomain corners and their 

coordinates appear in the 'Control points' box (Note that you could obtain a different order than the one in the 

figure below). These points are used to split the subdomain edges. Fill the split boxes in order to divide the 

edges AG in 15 parts and the edge GC in 20 parts and click on 'Create virtual mesh' at the bottom of the 

window. 
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Click inside the lower subdomain. In this case the control points are not automatically identified since the 

subdomain contour has more than 4 points (5 in this case). The control points have to be identified using the 

‘Pick’ command in the ‘Meshing Parameters’ window and clicking on the four subdomain corners (GDEF). 

Split the edge GD (1-2 in the figure) in 25 parts and the edge GF (1-4 in the figure) in 5 parts. Click on ‘Create 

virtual mesh’. 

 

    
 

The created virtual mesh has to be converted in a real mesh selecting on the right menu ‘MACRO MODEL > 

Subdomain > Mesh > Virtual → Real mesh’ and clicking inside the two subdomains. Note that the hydraulic 

boundary conditions specified in the macro model are correctly applied to each element of the real mesh. 

 

    
 

Once the mesh has been created, kinematic boundary conditions have to be applied. The preprocessor offers a 

simple way to apply classical displacement boundary conditions that prevent horizontal displacements for the 

nodes on the lateral edges of the domain, and any displacements for the nodes of the domain bottom. To do 

this, select on the right menu ‘FE model > Boundary conditions > Solid BC > On box’.  
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This concludes the use of the preprocessor. Click on ‘Data verification’ at the top right of the window to check 

if all the data have been input correctly. Select ‘File > Save model and return to main menu’. 

 

2.1.2   Definition of material parameters  

 

To define the material parameters select ‘Assembly > Materials’ from the Z_Soil main window. Select the first 

material, set as Continuum Elastic by default, and press ‘Modify’ to change its name and its formulation to 

Mohr – Coulomb.    

 

 

 
 

 

Set the Elastic, Unit weights, Flow and Non-linear properties by clicking ‘Open’ according to the values in 

Table 1. Note that since no material has been specified during the construction of the mesh, the material n.1 is 

applied by default to all elements. 

 

Define the Seepage material that will be assigned later to the corresponding subdomains edges. 

 

 

2.1.3   Definition of the loading function 

 

The definition of the loading functions lets us to choose easily the values of applied loads and fluxes and their 

evolutions with time. When load functions are used, the final values of the applied actions are obtained 

multiplying the assigned values in the preprocessor by the selected loading function. In our example, a flux 

equal to 1 m/h has been assigned to the horizontal upper surface (0.71 for the slope) and load function n.1 has 

been selected. We can choose the evolution of the infiltration with time defining opportunely the loading 

function for each of the cases to study. For example, when the problem (a) has to be solved we can select a 

constant value of the loading function equal to 0.012 m/h for 200 h. 

 

To define the loading function select ‘Assembly > Load function’ in the Z_Soil main window. Insert a name 

for the function number 1 (e.g. infiltration) and press ‘add’. The function is defined by points. 

 

Case (a) 

We can imagine that there is no infiltration at the initial state (t = 0), that the flux increases up to the final value 

in the first 4 hours and that it remains constant during all the analysis. To do that we have to introduce the 

point (0, 0) (write the values in the boxes), (4, 0.012) and (200, 0.012). 
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Case (b) 

Similarly when the problem (b) has to be solved, the loading function can be defined imaging that there is no 

flux at the initial state (t = 0), that the flux increases up to the final value in the first half hour and that it remains 

constant during all the analysis. To do that we have to introduce the point (0,_0) (write the values in the boxes), 

(0.5, 0.12) and (20, 0.12). 

 

 

 

2.1.4   Definition of the analysis drivers 

 

Close the preprocessing window to return to the main program where the sequence of the calculations can be 

specified selecting ‘Control > Drivers’.  

 

An initial state driver is used to define in situ stress state induced by gravity as well as other loads and fluxes 

acting at time instance t = 0. In our case, fluxes are not present at t = 0 according to the load function definition, 

and so the only specified condition for the fluid phase is the water table at the slope toe. An initial state with 

zero deformation and no–zero stress-state is generated. The default values for this driver can be applied. 

 

The Stability driver is then used to calculate the initial value of the safety factor (SF). This value is obtained 

reducing the material strength parameters (c’ and ’) following a given sequence and detecting if an 

equilibrated state is still possible. Stability driver can be used at any time, may be declared more than once in 

the driver list and it does not affect results of next drivers.  

Initial and final SF values must be inserted along with its increment. Here it is suggested to start from SF = 

1.15 up to SF = 1.3 with an increment of 0.01. Select Stability driver with ‘tg(phi),c’ type; insert SF initial, 

final and increment values and click ‘Add’. 

 

 
 

Case (a) 

A ‘Time dependent - Consolidation’ driver is used to solve the coupled system of equations including 

equilibrium and fluid flow continuity (deformations may influence variation of the pore pressure field and vice 

versa), in order to calculate the unknown node pressures and displacements. Initial and final time for the driver 
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have to be inserted along with the time increment. In this first step, the analysis is performed for the first 24 

hours and a time interval of 4 hours is proposed.  

 

 
 

To check the evolution of the safety factor during the rainfall event, we introduce at several points of the 

analysis a Stability driver with proper edge and increment values. After the SF calculation, the ‘Time 

dependent – Consolidation driver’ is recalled to continue the analysis. A complete sequence of the drivers that 

can be used is the following: 

 

 
 

 

Case (b) 

Similarly when problem (b) has to be solved, a driver sequence is used alternating stability and time dependent 

drivers with a total analysis duration of 20 hours and a time interval of 0.5 hour. 

 

Once the loading function is defined it is needed to assign it to the corresponding subdomain edge. In order to 

do that, go on the preprocessing window and select in the upper menu the command PARAMETERS and click 

on the geometrical representation of the flux (see figure below). 
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Following the same approach, it is needed to assign the material “seepage” to the corresponding subdomain 

edges. Open the Preprocessing window (‘Assembly > Preprocessing’) and click on PARAMETERS and 

click on the two lines as shown in the figure below: 

 

 
 

 

2.2   Calculation 
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When data input phase is completed, launch the calculation selecting ‘Analysis > Run Analysis’ from the main 

window menu. The calculation module window appears and the calculation progress can be followed.  

 

 
 

2.3   Postprocessing 

 

When calculation is finished, launch the postprocessor from the main window menu: ‘Results > 

Postprocessing’. The following window will appear: 

 

 
 

 
The postprocessor offers several tools to visualize and export data.  

From the menu ‘Setting > Units’ set the unit for time to hours.  

 

Note: depending on the software version, some differences may be encountered (e.g. the tab ‘Graph Option’ 

may be replaced by ‘Results’). 

 

Pore water pressure, effective stress and saturation degree distributions 

 

From the menu in the high right corner ‘current time’ (or in the top left corner form dropdown list) it is possible 

to select a time step; then select in tab ‘Graph Option > Maps’. The result to be visualized can be selected in 

the ‘Settings > Graph contents’. In the window we can select ‘Nodal quantities’ to visualize pore pressures and 

displacement, or ‘Continuum’ to visualize stresses and saturation degree. Graphical settings can be adjusted 

here. 

‘units’ 
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Once the variable has been selected, it is possible to switch among the calculation steps using the arrows ‘<’ 

and ‘>’ in the top right corner (or in the top left corner form dropdown list). This is very useful to see the 

evolution of the variables with time in the overall domain. 

 

Displacements 

 

To visualize the evolution of displacements with time for specified points select ‘Graph Option > Nodal time 

history’. Select the points of interest on the upper right window and click ‘Add’. With ‘Graph settings > Graph 

contents’ is possible to choose the variables displayed in the plot. 

 

 
 

 

 

Evolution of safety factor with time   

 

From menu ‘Time’ it is possible to visualize the calculation steps and to get information on their convergence. 

In our case, this is very useful since it is possible to check the last safety factor value for which convergence 

has been achieved for each stability driver. 
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